bootstrap4 教程

bootstrap 教程

bootstrap 是全球最受欢迎的前端组件库,用于开发响应式布局、移动设备优先的 web 项目。

bootstrap4 目前是 bootstrap 的最新版本,是一套用于 html、css 和 js 开发的开源工具集。利用我们提供的 sass 变量和大量 mixin、响应式栅格系统、可扩展的预制组件、基于 jquery 的强大的插件系统,能够快速为你的想法开发出原型或者构建整个 app 。

谁适合阅读本教程?

只要您具备 html 和 css 的基础知识,您就可以《can》阅读本教程,进而开发出自己《zì jǐ》的网站。在您学习完本教程后,您即可达到使用 bootstrap 开发 web 项目的中等水平。

阅读本教程前,您需要了解的知识:

在您开始《kāi shǐ》阅读本教程之前,您必须具备 html 、 css 和 javascript 的基础知识。如果您还不了解这些概念,那么建议您先阅读我们的这些教程:

bootstrap4 实例

bootstrap4 实例

<div class="jumbotron text-center"><h1>我的第一个 bootstrap 页面</h1><p>重置浏览器大小查看效果!</p></div><div class="container"><div class="row"><div class="col-sm-4"><h3>js随机数第一列</h3><p>菜鸟教程</p><p>学的不仅《bù jǐn》是技术,更是梦想!!!</p></div><div class="col-sm-4"><h3>第二列</h3><p>菜鸟教程..</p><p>学的不仅是技术,更是梦想!!!</p></div><div class="col-sm-4"><h3>第三列</h3><p>菜鸟教程..</p><p>学的不仅是技术,更是梦想!!!</p></div></div></div>

尝试一下 »

bootstrap4 与 bootstrap3

bootstrap4 是 bootstrap 的最新版本,与 bootstrap3 相比拥有了更多的具体的类以及把一些有关的部分变成了相关的组件。同时 bootstrap.min.css 的体积减少了40%以上。

bootstrap4 放弃了对 ie8 以及 ios 6 的支持《zhī chí》,现在仅仅支持《zhī chí》 ie9 以上 以及 ios 7 以上版本的浏览器。如果对于其中需要用到以前的浏览器,那么请使用 bootstrap3